Anime i manga en català

Moderadors: Guiru, Maki

 
Avatar de l’usuari
bitERROR
Ryushinchu
Ryushinchu
Entrades: 2808
Membre des de: dt. 16 des. 2003, 01:57
Ubicació: El cajón de las braguitas
Contacta:

Vídeos HD i Linux

dv. 29 oct. 2010, 12:58

Tinc problemes per reproduir vídeos HD 1080p comprimits amb x264 als meus Ubuntu 10.04 del portàtil i el PC.

Quan intento reproduir un vídeo amb aquesta resolució s'atura constantment, passa més temps la imatge congelada que en moviment. Tots dos ordinadors tenen prou hardware i els drivers correctes.

He estat mirant pel google i lo primer que havia de fer era lo més obvi, instal·lar el x264. Ho he fet i continuo igual.

La solució més estessa que he trobat ha estat la de instal·lar el CoreAVC de Windows mitjançant wine, ja que la diferència entre aquest i el ffmpeg és que el CoreAVC fa servir tots els nuclis de la CPU i el ffmpeg, no (amb el H.264 com a mínim, només empra un).

M'agradaria saber si algú ha trobat una alternativa per poder reproduir això sense el CoreAVC.
Imatge Imatge
 
Avatar de l’usuari
xose
Sushinchu
Sushinchu
Entrades: 744
Membre des de: dl. 19 set. 2005, 19:33
Ubicació: Al fondo a la derecha
Contacta:

Re: Vídeos HD i Linux

dv. 29 oct. 2010, 13:08

I provant un altre reproductor natiu de Linux? (VLC, per exemple)
Imatge
Imatge
 
Avatar de l’usuari
bitERROR
Ryushinchu
Ryushinchu
Entrades: 2808
Membre des de: dt. 16 des. 2003, 01:57
Ubicació: El cajón de las braguitas
Contacta:

Re: Vídeos HD i Linux

dv. 29 oct. 2010, 17:22

He provat amb el mplayer, el totem (vé de sèrie amb ubuntu) i el VLC.

El mplayer no pot reproduir-me'l, amb el totem i el VLC tinc el problema dels "salts".

Tinc altres vídeos fets amb x264 però de 480p que se'm reprodueixen sense problema.
Imatge Imatge
 
Avatar de l’usuari
Elwe
Moderadors
Moderadors
Entrades: 1904
Membre des de: ds. 11 oct. 2003, 19:57

Re: Vídeos HD i Linux

dv. 29 oct. 2010, 23:54

I amb el Dragon Player ho has provat? És un reproductor força lleuger.

:adeu:
 
Avatar de l’usuari
bitERROR
Ryushinchu
Ryushinchu
Entrades: 2808
Membre des de: dt. 16 des. 2003, 01:57
Ubicació: El cajón de las braguitas
Contacta:

Re: Vídeos HD i Linux

dc. 10 nov. 2010, 19:32

Vaig provar la setmana passada el Dragon Player però tampoc no funciona, fa lo mateix que el VLC.

He provat a alleugerar s'arxiu, és un mkv amb molts àudios i subtítols, deixant-lo amb només un àudio i uns subtítols. La cosa millora una mica però encara lluny d'algo acceptable.

Però això em fa dubtar que no sigui cosa de recursos:
Intel Dual Core 3,2GHz 32bit
Nvidia Geforce LE 512Mb amb s'acceleració activada
1Gb de RAM (no s'arriba a consumir ni el 40% mentre s'intenta reproduir)

Llàstima que no tingui cap windows que funcioni en aquest PC per provar el CoreAVC aquest.
Imatge Imatge
 
Avatar de l’usuari
Krovikan
Arashinchu
Arashinchu
Entrades: 134
Membre des de: dc. 03 des. 2003, 22:36
Ubicació: Davant de l'ordinador

Re: Vídeos HD i Linux

dc. 10 nov. 2010, 20:36

Només 1Gb de RAM?

Mira que tinc curiositat pel teu vídeo a veure si a mi em faria el mateix. Jo en tinc 8Gb de RAM i 6 cores (és un Phenom II X6 1055T).

Si puges un trocet de vídeo miro si a mi també m'ho fa.


Salutacions
:tux: Imatge :tux:
ImatgeImatge
 
Avatar de l’usuari
Bilkoff
Moderadors
Moderadors
Entrades: 788
Membre des de: dt. 05 oct. 2004, 19:22
Ubicació: Borriana
Contacta:

Re: Vídeos HD i Linux

dc. 10 nov. 2010, 22:33

I si desactives l'acceleració de la gràfica? Amb 3.2GHz de processador no es necessari tirar de gràfica per a reproduir perfectament.
 
Avatar de l’usuari
Krovikan
Arashinchu
Arashinchu
Entrades: 134
Membre des de: dc. 03 des. 2003, 22:36
Ubicació: Davant de l'ordinador

Re: Vídeos HD i Linux

dj. 11 nov. 2010, 00:36

Això em recorda que per fer anar bé el World of Warcraft tinc que desactivar els efectes d'escriptori.

Has provat a desactivar-los?


Salutacions
:tux: Imatge :tux:

ImatgeImatge
 
Avatar de l’usuari
bitERROR
Ryushinchu
Ryushinchu
Entrades: 2808
Membre des de: dt. 16 des. 2003, 01:57
Ubicació: El cajón de las braguitas
Contacta:

Re: Vídeos HD i Linux

dj. 11 nov. 2010, 12:45

Crec que tinc algun problema més de fons amb aquest PC; no ho he dit però en general no va tant fi com hauria d'anar.

Portàtil
Però al cas, he provat amb es Vista des portàtil i la darrera versió del VLC (1.1.4) i m'ha anat bé.

Així que he pensat que si el VLC 1.1.4 al Vista va bé, perquè no al Ubuntu? Idò, al Ubuntu tenia la versió 1.0.6, l'he actualitzada seguint les instruccions de la web oficial i ha anat bé, per fi!

Ubuntu 10.04 té el VLC 1.0.6 als repositoris, que com diu a la web està desfasada.
Ubuntu 10.10 ja té el VLC 1.1.4 als repositoris, així que la solució també hauria estat upgradejar el s.o.

PC
He fet lo mateix, he actualitzat a VLC 1.1.4 i si bé la cosa ha millorat molt, li falta una mica per ser "acceptable".

He actualitzat els drivers d'nVidia amb els privatius i eliminat un experimental que du l'Ubuntu 10.04, un tal Nouveau. I res, no n'hi ha prou per veure-lo bé.

Com deia al principi, aquí tinc algun problema de base que afecta al rendiment general d'aquest PC, i que no ve al cas del fil.

Krovikan ha escrit:
Mira que tinc curiositat pel teu vídeo a veure si a mi em faria el mateix. Jo en tinc 8Gb de RAM i 6 cores (és un Phenom II X6 1055T).

Si puges un trocet de vídeo miro si a mi també m'ho fa.

Amb aquest tros de màquina si no te'l reprodugués seria per fer-te l'harakiri.
El vídeo en qüestió és el primer capítol de Casshern Sins d'AniMugen Fansub.

Krovikan ha escrit:
Només 1Gb de RAM?

Sí, un dia ho hauria d'ampliar... però aparantment no és problema perquè com dic no n'arriba a mester ni la meitat durant sa reproducció.

Krovikan ha escrit:
desactivar els efectes d'escriptori

Sí, he provat matant directament el compiz i l'emerald, i res.

Bilkoff ha escrit:
I si desactives l'acceleració de la gràfica?

No ho he sabut fer. ^^u
Imatge Imatge
 
Avatar de l’usuari
Krovikan
Arashinchu
Arashinchu
Entrades: 134
Membre des de: dc. 03 des. 2003, 22:36
Ubicació: Davant de l'ordinador

Re: Vídeos HD i Linux

dj. 11 nov. 2010, 19:46

bitERROR ha escrit:
El vídeo en qüestió és el primer capítol de Casshern Sins d'AniMugen Fansub.


M'has matat. Fa anys que no uso la mula. I ja passo d'ella. ^^u

bitERROR ha escrit:
No ho he sabut fer. ^^u


Posa un driver genèric. Ni noveau, ni nv. Un que serveixi per tenir les X solsament.


Salutacions
:tux: Imatge :tux:

ImatgeImatge
 
Avatar de l’usuari
Mad93
Moderadors
Moderadors
Entrades: 5850
Membre des de: dj. 27 nov. 2003, 20:00
Ubicació: Vivint a la universitat ><
Contacta:

Re: Vídeos HD i Linux

dv. 31 des. 2010, 21:36

Si tens els drivers 3D pots provar diverses combinacions amb el mplayer.

mplayer -vo opengl
mplayer -vo xv
mplayer -vo sdl
mplayer -vo opengl2

i alguna més que hi ha.

Llavors en una consola (amb el vídeo en primer pla) deixes executant la comanda "top" i veus el que gasta de cpu en cada cas.
Imatge
Tant avorrit que m'he fet un bloc... un més. Servidor mig online...

Qui està connectat

Usuaris navegant en aquest fòrum: No hi ha cap usuari registrat i 1 visitant